How to make the nodes more distributed initially?

Apr 28, 2010 at 10:04 AM
Edited Apr 28, 2010 at 10:05 AM

I found nodes created initially stick together(both expanded and unexpanded). this problem can be solved only when I drag those expanded nodes. How to make the nodes more distributed initially?

Coordinator
May 3, 2010 at 2:48 PM

I think you're simply having a scale issue. If you reduce the size of your nodes (use the config file), and zoom in a little more for your initial view (again, config file), you'll find that the node don't overlap anymore. Let me know if that worked for you.

May 7, 2010 at 2:26 AM

Thanks for the help, I reconfigured it but it's still not working

On my Ccomputer it is like this:

 I may created same nodes twice in my code, it also maybe where error occurs...

Coordinator
May 8, 2010 at 3:13 PM

So it seems that the strength of the links in the middle is too strong, compared to the strength of the links of the more remote nodes. I don't know how the strength is calculated in your particular scenario, in general the strength is set up when you create the link with the attribute link.strength (see page 23 of the tutorial).  When I'm not sure what value an algorithm returns for a link strength, I usually display the strength value in the grammar (e.g.  link.grammar.complement = "in alphabetical order " + link.strength;), so when I pass the mouse over the link I can see the strength value for this particular link. This helps me figure any issue with my strength algorithm. 

Hope this helps.

 

Coordinator
May 13, 2010 at 2:53 PM
Edited May 13, 2010 at 2:54 PM

Hi,

Maybe you can try to enhance the repultion force.

Please take attention to this part of the configuration file:

 

<physicsConstants>
 <!--  (Optional) Drag force that acts on all objects equally, and proportional to velocity. The higher the value, the quicker particules will stop moving around. Null or negative value may lead to a crash of the physics engine
  --> 
  <fluidResistance>0.25</fluidResistance> 
 <!--  (Optional) Gravity goes between -10 and 10 (integer). Use negative number to see nodes "flying" instead of dropping. Use 0 for no gravity. 
  --> 
  <gravity>0</gravity> 
 <!--  (Optional) Rest length is the optimal distance between to related nodes.
  --> 
  <springRestLenght>5</springRestLenght> 
 <!--  (Optional) Repultion strength define the force of repultion between each particle
  --> 
  <repultionStrength>1000</repultionStrength> 
</physicsConstants>

 

Sep 9, 2010 at 6:27 PM

Hi,

I'm also having the same issue. When the control loads initially it is not readable, all 4 nodes are put on each other.

My configuration file does contain all the settings like "cpoirot" has described, and I've already tried increasing/decreasing the "strength" property of the link object. Nothing seems to change. Any other suggestions ?

Thanks.